using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:https?:\/\/)?[^\/:]+\/.*?checkout\/b\?bag=?([A-Za-z0-9]*)$";
string input = @"https://jasongarnerppf3f6.volusionplatformdev.com/checkout/b?bag=5ab1235aebd29702dc547df7";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}