const regex = /\b(?:https?:\/\/)?[^\/:]+\/.*?checkout\/b\?bag=?([A-Za-z0-9]*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:https?:\\\/\\\/)?[^\\\/:]+\\\/.*?checkout\\\/b\\?bag=?([A-Za-z0-9]*)$', 'g')
const str = `https://jasongarnerppf3f6.volusionplatformdev.com/checkout/b?bag=5ab1235aebd29702dc547df7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}