package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:https?:\/\/)?[^\/:]+\/.*?checkout\/b\?bag=?([A-Za-z0-9]*)$`)
var str = `https://jasongarnerppf3f6.volusionplatformdev.com/checkout/b?bag=5ab1235aebd29702dc547df7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}