import Foundation
let pattern = #"\b(?:https?:\/\/)?[^\/:]+\/.*?checkout\/b\?bag=?([A-Za-z0-9]*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://jasongarnerppf3f6.volusionplatformdev.com/checkout/b?bag=5ab1235aebd29702dc547df7"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)