using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http(s?):/)(/[^/]+)+\"" + \""\.(?:jpg|gif|png)";
string input = @"http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3"" "".jpg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}