import re
regex = re.compile(r"(http(s?):/)(/[^/]+)+\" + \"\.(?:jpg|gif|png)")
test_str = "http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3\" \".jpg"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")