$re = '/(http(s?):/)(/[^/]+)+\" + \"\.(?:jpg|gif|png)/';
$str = 'http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3" ".jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);