import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s?):/)(/[^/]+)+\\\" + \\\"\\.(?:jpg|gif|png)";
final String string = "http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3\" \".jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}