re = /(http(s?):\/)(\/[^\/]+)+\" + \"\.(?:jpg|gif|png)/
str = 'http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3" ".jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end