using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s]?_[^\s]*|\s?([^_\s]*)\s+?";
string input = @"private string __$id0 = ""lala""
__$id0 = ""lala""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}