$re = '/[\s]?_[^\s]*|\s?([^_\s]*)\s+?/';
$str = 'private string __$id0 = "lala"
__$id0 = "lala"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);