re = /[\s]?_[^\s]*|\s?([^_\s]*)\s+?/
str = 'private string __$id0 = "lala"
__$id0 = "lala"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end