import re
regex = re.compile(r"[\s]?_[^\s]*|\s?([^_\s]*)\s+?")
test_str = ("private string __$id0 = \"lala\"\n"
"__$id0 = \"lala\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")