#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:www\.)?[a-z]+(?:[-][a-z]+)+\.(?:com|org)(?:\.[a-z]{2,3})?"
Local $sString = "http://www.some-thing.org" & @CRLF & _
"www.some-thing.org" & @CRLF & _
"some-thing.org" & @CRLF & _
"some-thing.org.sg" & @CRLF & _
"some-thing.com" & @CRLF & _
"some-thing.com.sg" & @CRLF & _
"" & @CRLF & _
"this-is-valid.com" & @CRLF & _
"" & @CRLF & _
"invalid.com" & @CRLF & _
"" & @CRLF & _
"some-thing" & @CRLF & _
"some-thing.moc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")