// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https?:\/\/)?(?:www\.)?[a-z]+(?:[-][a-z]+)+\.(?:com|org)(?:\.[a-z]{2,3})?").unwrap();
let string = "http://www.some-thing.org
www.some-thing.org
some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
this-is-valid.com
invalid.com
some-thing
some-thing.moc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}