re = /(?:https?:\/\/)?(?:www\.)?[a-z]+(?:[-][a-z]+)+\.(?:com|org)(?:\.[a-z]{2,3})?/
str = 'http://www.some-thing.org
www.some-thing.org
some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
this-is-valid.com
invalid.com
some-thing
some-thing.moc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end