const regex = /(?:https?:\/\/)?(?:www\.)?[a-z]+(?:[-][a-z]+)+\.(?:com|org)(?:\.[a-z]{2,3})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?(?:www\\.)?[a-z]+(?:[-][a-z]+)+\\.(?:com|org)(?:\\.[a-z]{2,3})?', 'g')
const str = `http://www.some-thing.org
www.some-thing.org
some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
this-is-valid.com
invalid.com
some-thing
some-thing.moc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}