package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:https?:\/\/)?(?:www\.)?[a-z]+(?:[-][a-z]+)+\.(?:com|org)(?:\.[a-z]{2,3})?`)
var str = `http://www.some-thing.org
www.some-thing.org
some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
this-is-valid.com
invalid.com
some-thing
some-thing.moc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}