#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)#file "([^"]*)";;((?:(?!#file).)*)"
Local $sString = "#file "scripts\generate.c";;" & @CRLF & _
"void Generate()" & @CRLF & _
"" & @CRLF & _
"adsasd" & @CRLF & _
"asdasdas" & @CRLF & _
"asdasd" & @CRLF & _
"#file "a.c";;" & @CRLF & _
"void asdad()" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")