import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#file \"([^\"]*)\";;((?:(?!#file).)*)";
final String string = "#file \"scripts\\generate.c\";;\n"
+ "void Generate()\n\n"
+ "adsasd\n"
+ "asdasdas\n"
+ "asdasd\n"
+ "#file \"a.c\";;\n"
+ "void asdad()\n"
+ "asdasd\n"
+ "asdasd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}