using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#file ""([^""]*)"";;((?:(?!#file).)*)";
string input = @"#file ""scripts\generate.c"";;
void Generate()
adsasd
asdasdas
asdasd
#file ""a.c"";;
void asdad()
asdasd
asdasd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}