$re = '/#file "([^"]*)";;((?:(?!#file).)*)/ims';
$str = '#file "scripts\\generate.c";;
void Generate()
adsasd
asdasdas
asdasd
#file "a.c";;
void asdad()
asdasd
asdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);