re = /#file "([^"]*)";;((?:(?!#file).)*)/im
str = '#file "scripts\\generate.c";;
void Generate()
adsasd
asdasdas
asdasd
#file "a.c";;
void asdad()
asdasd
asdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end