#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-fA-F0-9]{1,2}(:[a-fA-F0-9]{1,2}){3,})"
Local $sString = "this is a test of af" & @CRLF & _
"this is a test of af:Af" & @CRLF & _
"this is a test of af:Af:Af" & @CRLF & _
"this is a test of af:Af:Af:Af" & @CRLF & _
"this is a test of af:Af:Af:Af:Af" & @CRLF & _
"this is a test of af:Af:Af:Af:Af:AF" & @CRLF & _
"" & @CRLF & _
"Linux hostname 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")