$re = '/([a-fA-F0-9]{1,2}(:[a-fA-F0-9]{1,2}){3,})/m';
$str = 'this is a test of af
this is a test of af:Af
this is a test of af:Af:Af
this is a test of af:Af:Af:Af
this is a test of af:Af:Af:Af:Af
this is a test of af:Af:Af:Af:Af:AF
Linux hostname 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);