import re
regex = re.compile(r"([a-fA-F0-9]{1,2}(:[a-fA-F0-9]{1,2}){3,})", flags=re.MULTILINE)
test_str = ("this is a test of af\n"
"this is a test of af:Af\n"
"this is a test of af:Af:Af\n"
"this is a test of af:Af:Af:Af\n"
"this is a test of af:Af:Af:Af:Af\n"
"this is a test of af:Af:Af:Af:Af:AF\n\n"
"Linux hostname 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")