using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-fA-F0-9]{1,2}(:[a-fA-F0-9]{1,2}){3,})";
string input = @"this is a test of af
this is a test of af:Af
this is a test of af:Af:Af
this is a test of af:Af:Af:Af
this is a test of af:Af:Af:Af:Af
this is a test of af:Af:Af:Af:Af:AF
Linux hostname 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}