// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-fA-F0-9]{1,2}(:[a-fA-F0-9]{1,2}){3,})").unwrap();
let string = "this is a test of af
this is a test of af:Af
this is a test of af:Af:Af
this is a test of af:Af:Af:Af
this is a test of af:Af:Af:Af:Af
this is a test of af:Af:Af:Af:Af:AF
Linux hostname 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}