using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<artist>[a-zA-Z\ \-_]*)/(?P<album_year>\d\d\d\d) (?P<album_title>[a-zA-Z\ \-_]*)/(?P<track_num>[\d]+) (?P<track_title>[a-zA-Z\ \-_]*)\.mp3";
string input = @"Queen/1975 A Night At The Opera/01 Death on Two Legs.mp3
Queen/1975 A Night At The Opera/11 Bohemian Rhapsody.mp3
Queen/1989 The Miracle/04 I Want It All.mp3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}