package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<artist>[a-zA-Z\ \-_]*)/(?P<album_year>\d\d\d\d) (?P<album_title>[a-zA-Z\ \-_]*)/(?P<track_num>[\d]+) (?P<track_title>[a-zA-Z\ \-_]*)\.mp3`)
var str = `Queen/1975 A Night At The Opera/01 Death on Two Legs.mp3
Queen/1975 A Night At The Opera/11 Bohemian Rhapsody.mp3
Queen/1989 The Miracle/04 I Want It All.mp3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}