use strict;
my $str = 'Queen/1975 A Night At The Opera/01 Death on Two Legs.mp3
Queen/1975 A Night At The Opera/11 Bohemian Rhapsody.mp3
Queen/1989 The Miracle/04 I Want It All.mp3
';
my $regex = qr/^(?P<artist>[a-zA-Z\ \-_]*)/(?P<album_year>\d\d\d\d) (?P<album_title>[a-zA-Z\ \-_]*)/(?P<track_num>[\d]+) (?P<track_title>[a-zA-Z\ \-_]*)\.mp3/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}