re = /^(?P<artist>[a-zA-Z\ \-_]*)\/(?P<album_year>\d\d\d\d) (?P<album_title>[a-zA-Z\ \-_]*)\/(?P<track_num>[\d]+) (?P<track_title>[a-zA-Z\ \-_]*)\.mp3/m
str = 'Queen/1975 A Night At The Opera/01 Death on Two Legs.mp3
Queen/1975 A Night At The Opera/11 Bohemian Rhapsody.mp3
Queen/1989 The Miracle/04 I Want It All.mp3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end