# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<artist>[a-zA-Z\ \-_]*)/(?P<album_year>\d\d\d\d) (?P<album_title>[a-zA-Z\ \-_]*)/(?P<track_num>[\d]+) (?P<track_title>[a-zA-Z\ \-_]*)\.mp3"
test_str = ("Queen/1975 A Night At The Opera/01 Death on Two Legs.mp3\n"
"Queen/1975 A Night At The Opera/11 Bohemian Rhapsody.mp3\n"
"Queen/1989 The Miracle/04 I Want It All.mp3\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.