#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!plugins/(arve-|advanced-re|edd-)).+"
Local $sString = "plugins/advanced-responsive-video-embedder" & @CRLF & _
"plugins/arve-amp" & @CRLF & _
"plugins/arve-pro" & @CRLF & _
"plugins/arve-random-video" & @CRLF & _
"plugins/arve-sticky-videos" & @CRLF & _
"plugins/boilerplate" & @CRLF & _
"plugins/classic-editor" & @CRLF & _
"plugins/composer-local" & @CRLF & _
"plugins/debug-bar" & @CRLF & _
"plugins/debug-bar-actions-and-filters-addon" & @CRLF & _
"plugins/debug-bar-constants" & @CRLF & _
"plugins/debug-bar-shortcodes" & @CRLF & _
"plugins/debug-bar-slow-actions" & @CRLF & _
"plugins/disabler" & @CRLF & _
"plugins/edd-better-checkout" & @CRLF & _
"plugins/edd-bootstrap-styles" & @CRLF & _
"plugins/example2" & @CRLF & _
"plugins/gutenberg" & @CRLF & _
"plugins/gutenberg-boilerplate" & @CRLF & _
"plugins/jd-shortcode" & @CRLF & _
"plugins/n-arve-divi-workaround" & @CRLF & _
"plugins/n-arve-divi-workaround.zip" & @CRLF & _
"plugins/n-arve-invidious" & @CRLF & _
"plugins/n-arve-rest-api" & @CRLF & _
"plugins/n-arve-videojs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")