using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!plugins/(arve-|advanced-re|edd-)).+";
string input = @"plugins/advanced-responsive-video-embedder
plugins/arve-amp
plugins/arve-pro
plugins/arve-random-video
plugins/arve-sticky-videos
plugins/boilerplate
plugins/classic-editor
plugins/composer-local
plugins/debug-bar
plugins/debug-bar-actions-and-filters-addon
plugins/debug-bar-constants
plugins/debug-bar-shortcodes
plugins/debug-bar-slow-actions
plugins/disabler
plugins/edd-better-checkout
plugins/edd-bootstrap-styles
plugins/example2
plugins/gutenberg
plugins/gutenberg-boilerplate
plugins/jd-shortcode
plugins/n-arve-divi-workaround
plugins/n-arve-divi-workaround.zip
plugins/n-arve-invidious
plugins/n-arve-rest-api
plugins/n-arve-videojs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}