import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!plugins/(arve-|advanced-re|edd-)).+";
final String string = "plugins/advanced-responsive-video-embedder\n"
+ "plugins/arve-amp\n"
+ "plugins/arve-pro\n"
+ "plugins/arve-random-video\n"
+ "plugins/arve-sticky-videos\n"
+ "plugins/boilerplate\n"
+ "plugins/classic-editor\n"
+ "plugins/composer-local\n"
+ "plugins/debug-bar\n"
+ "plugins/debug-bar-actions-and-filters-addon\n"
+ "plugins/debug-bar-constants\n"
+ "plugins/debug-bar-shortcodes\n"
+ "plugins/debug-bar-slow-actions\n"
+ "plugins/disabler\n"
+ "plugins/edd-better-checkout\n"
+ "plugins/edd-bootstrap-styles\n"
+ "plugins/example2\n"
+ "plugins/gutenberg\n"
+ "plugins/gutenberg-boilerplate\n"
+ "plugins/jd-shortcode\n"
+ "plugins/n-arve-divi-workaround\n"
+ "plugins/n-arve-divi-workaround.zip\n"
+ "plugins/n-arve-invidious\n"
+ "plugins/n-arve-rest-api\n"
+ "plugins/n-arve-videojs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}