$re = '#^(?!plugins/(arve-|advanced-re|edd-)).+#m';
$str = 'plugins/advanced-responsive-video-embedder
plugins/arve-amp
plugins/arve-pro
plugins/arve-random-video
plugins/arve-sticky-videos
plugins/boilerplate
plugins/classic-editor
plugins/composer-local
plugins/debug-bar
plugins/debug-bar-actions-and-filters-addon
plugins/debug-bar-constants
plugins/debug-bar-shortcodes
plugins/debug-bar-slow-actions
plugins/disabler
plugins/edd-better-checkout
plugins/edd-bootstrap-styles
plugins/example2
plugins/gutenberg
plugins/gutenberg-boilerplate
plugins/jd-shortcode
plugins/n-arve-divi-workaround
plugins/n-arve-divi-workaround.zip
plugins/n-arve-invidious
plugins/n-arve-rest-api
plugins/n-arve-videojs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);