const regex = new RegExp('^(?!plugins/(arve-|advanced-re|edd-)).+', 'gm')
const str = `plugins/advanced-responsive-video-embedder
plugins/arve-amp
plugins/arve-pro
plugins/arve-random-video
plugins/arve-sticky-videos
plugins/boilerplate
plugins/classic-editor
plugins/composer-local
plugins/debug-bar
plugins/debug-bar-actions-and-filters-addon
plugins/debug-bar-constants
plugins/debug-bar-shortcodes
plugins/debug-bar-slow-actions
plugins/disabler
plugins/edd-better-checkout
plugins/edd-bootstrap-styles
plugins/example2
plugins/gutenberg
plugins/gutenberg-boilerplate
plugins/jd-shortcode
plugins/n-arve-divi-workaround
plugins/n-arve-divi-workaround.zip
plugins/n-arve-invidious
plugins/n-arve-rest-api
plugins/n-arve-videojs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}