using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<post author=""(.*?)""";
string input = @"<post author=""luckylindyslocale"" datetime=""2012-03-03T04:52:00"" id=""p7"">
<img src=""http://img.photobucket.com/albums/v303/lucky196/siggies/ls1.png""/>
Grams thank you, for this wonderful tag and starting this thread. I needed something to encourage me to start making some new tags.
<img src=""http://img.photobucket.com/albums/v303/lucky196/holidays/stpatlucky.jpg""/>
Cruelty is one fashion statement we can all do without. ~Rue McClanahan
</post>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}