// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<post author="(.*?)""#).unwrap();
let string = "<post author=\"luckylindyslocale\" datetime=\"2012-03-03T04:52:00\" id=\"p7\">
<img src=\"http://img.photobucket.com/albums/v303/lucky196/siggies/ls1.png\"/>
Grams thank you, for this wonderful tag and starting this thread. I needed something to encourage me to start making some new tags.
<img src=\"http://img.photobucket.com/albums/v303/lucky196/holidays/stpatlucky.jpg\"/>
Cruelty is one fashion statement we can all do without. ~Rue McClanahan
</post>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}