import re
regex = re.compile(r"<post author=\"(.*?)\"")
test_str = ("<post author=\"luckylindyslocale\" datetime=\"2012-03-03T04:52:00\" id=\"p7\">\n"
"<img src=\"http://img.photobucket.com/albums/v303/lucky196/siggies/ls1.png\"/>\n\n"
"Grams thank you, for this wonderful tag and starting this thread. I needed something to encourage me to start making some new tags.\n\n"
"<img src=\"http://img.photobucket.com/albums/v303/lucky196/holidays/stpatlucky.jpg\"/>\n"
"Cruelty is one fashion statement we can all do without. ~Rue McClanahan\n"
"</post>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")