import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<post author=\"(.*?)\"";
final String string = "<post author=\"luckylindyslocale\" datetime=\"2012-03-03T04:52:00\" id=\"p7\">\n"
+ "<img src=\"http://img.photobucket.com/albums/v303/lucky196/siggies/ls1.png\"/>\n\n"
+ "Grams thank you, for this wonderful tag and starting this thread. I needed something to encourage me to start making some new tags.\n\n"
+ "<img src=\"http://img.photobucket.com/albums/v303/lucky196/holidays/stpatlucky.jpg\"/>\n"
+ "Cruelty is one fashion statement we can all do without. ~Rue McClanahan\n"
+ "</post>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}