package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)status\\\":(?<status>\d+)`)
var str = `{"timestamp":"2022-03-04T11:04:41.143Z","message":"ABCDEFG :::{\"status\":200,\"headers\":
{"timestamp":"2022-03-05T11:02:41.143Z","message":"ABCDEFG :::{\"status\":400,\"headers\":
{"timestamp":"2022-03-02T11:05:41.143Z","message":"ABCDEFG :::{\"status\":500,\"headers\":`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}