// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)status\\\":(?<status>\d+)"#).unwrap();
let string = "{\"timestamp\":\"2022-03-04T11:04:41.143Z\",\"message\":\"ABCDEFG :::{\\\"status\\\":200,\\\"headers\\\":
{\"timestamp\":\"2022-03-05T11:02:41.143Z\",\"message\":\"ABCDEFG :::{\\\"status\\\":400,\\\"headers\\\":
{\"timestamp\":\"2022-03-02T11:05:41.143Z\",\"message\":\"ABCDEFG :::{\\\"status\\\":500,\\\"headers\\\":";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}