$re = '/status\\\\\":(?<status>\d+)/m';
$str = '{"timestamp":"2022-03-04T11:04:41.143Z","message":"ABCDEFG :::{\\"status\\":200,\\"headers\\":
{"timestamp":"2022-03-05T11:02:41.143Z","message":"ABCDEFG :::{\\"status\\":400,\\"headers\\":
{"timestamp":"2022-03-02T11:05:41.143Z","message":"ABCDEFG :::{\\"status\\":500,\\"headers\\":';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);