use strict;
my $str = '{"timestamp":"2022-03-04T11:04:41.143Z","message":"ABCDEFG :::{\\"status\\":200,\\"headers\\":
{"timestamp":"2022-03-05T11:02:41.143Z","message":"ABCDEFG :::{\\"status\\":400,\\"headers\\":
{"timestamp":"2022-03-02T11:05:41.143Z","message":"ABCDEFG :::{\\"status\\":500,\\"headers\\":';
my $regex = qr/status\\\":(?<status>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}