const regex = /status\\\":(?<status>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('status\\\\\\":(?<status>\\d+)', 'gm')
const str = `{"timestamp":"2022-03-04T11:04:41.143Z","message":"ABCDEFG :::{\\"status\\":200,\\"headers\\":
{"timestamp":"2022-03-05T11:02:41.143Z","message":"ABCDEFG :::{\\"status\\":400,\\"headers\\":
{"timestamp":"2022-03-02T11:05:41.143Z","message":"ABCDEFG :::{\\"status\\":500,\\"headers\\":`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}