# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=[a-z]{4}$).*[ae]//gm;t' <<< "akes
aejs
soae
skea
esao
sdhg
"