$re = '/^(?=[a-z]{4}$).*[ae]/m';
$str = 'akes
aejs
soae
skea
esao
sdhg
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;