import re
regex = re.compile(r"^(?=[a-z]{4}$).*[ae]", flags=re.MULTILINE)
test_str = ("akes\n"
"aejs\n"
"soae\n"
"skea\n"
"esao\n"
"sdhg\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)